Jump to content

Recommended Posts

I figured I'd make a little post with my experience with Windows 10 so far and what does and does not work with it.


Programs that work:

  • Premiere Pro CS6
  • After Effects CS6
  • Photoshop CS6
  • Audition CS6
  • Adobe Media Encoder
  • Dxtory 2.0.131 (seems to hang for ~30 seconds when you stop recording - counter is orange and says "FIN" underneath but goes away eventually)
  • Steam
  • Google Chrome
  • Dropbox
  • Windows Media Player

Games that work that I've randomly spot tested (I'd assume most games should work fine, I mostly just briefly launched the following games so there may be other bugs within):

  • Minecraft - loaded a test world and ran around. FPS seemed to be about the same as Win 7.
  • Half Life 2
  • Adventure Capitalist
  • Cities Skylines
  • Farming Simulator 2015



Quirks I've run into:


I got the following error code when trying to upgrade Windows 7 Pro to Windows 10: 0x80070004 0x3000D "...failed in the FIRST_BOOT phase with an error during MIGRATE_DATA". I think this is caused by having files that can't be migrated in your documents, desktop, etc. I moved all my personal documents from my user account to external storage (moved them to my nas, or you can move them to a USB hard drive). Then I moved them back after I upgraded. If you move your documents and still get the error, make sure you've moved ALL your documents and then the next time you try the upgrade tell it to not migrate your data in the upgrade installer. Other things I tried that I don't think were a factor - uninstalled anti-virus and installed all optional Windows updates.


EDIT: There are some log files at C:\$WINDOWS.~BT\Sources\Panther that might help you. You might want to start at the Sources folder and do a Windows search for *.log. I think the log file I used was in the Panther folder called setupact.log - there's a lot of technical stuff in there so scroll down near the bottom and look for errors that might indicate what the installer was doing before it failed. You will probably have to enable hidden files and folders, and uncheck hide protected operating system files.


I'll update this post as I get more info. So far I haven't found anything that explicitly doesn't work.

Edited by Stylez
Added info about log files
Link to post
Share on other sites
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.